aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2012-08-02 19:23:11 +0200
committerMax Kellermann <max@duempel.org>2012-08-02 19:25:18 +0200
commite08d4f28aae701431d361944786f0bfeae3a29fc (patch)
tree9fb254e016b8d5e4a403af0bbce5430cde9639d4 /Makefile.am
parent6f3c65dc647673e20960ba8546db25ae66898ede (diff)
downloadmpd-e08d4f28aae701431d361944786f0bfeae3a29fc.tar.gz
mpd-e08d4f28aae701431d361944786f0bfeae3a29fc.tar.xz
mpd-e08d4f28aae701431d361944786f0bfeae3a29fc.zip
Makefile.am: add libdb_plugins.a
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0c9817b05..e571520cd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,6 +12,7 @@ noinst_LIBRARIES = \
libpcm.a \
libtag.a \
libinput.a \
+ libdb_plugins.a \
libplaylist_plugins.a \
libdecoder_plugins.a \
libfilter_plugins.a \
@@ -23,6 +24,7 @@ src_mpd_CPPFLAGS = $(AM_CPPFLAGS) \
$(LIBWRAP_CFLAGS) \
$(SQLITE_CFLAGS)
src_mpd_LDADD = \
+ $(DB_LIBS) \
$(PLAYLIST_LIBS) \
$(AVAHI_LIBS) \
$(LIBWRAP_LDFLAGS) \
@@ -260,7 +262,6 @@ src_mpd_SOURCES = \
src/DatabasePlugin.hxx \
src/DatabaseVisitor.hxx \
src/db_selection.h \
- src/db/SimpleDatabasePlugin.cxx src/db/SimpleDatabasePlugin.hxx \
src/exclude.c \
src/fd_util.c \
src/fifo_buffer.c src/fifo_buffer.h \
@@ -429,6 +430,14 @@ if HAVE_LIBSAMPLERATE
libpcm_a_SOURCES += src/pcm_resample_libsamplerate.c
endif
+# database plugins
+
+libdb_plugins_a_SOURCES = \
+ src/db/SimpleDatabasePlugin.cxx src/db/SimpleDatabasePlugin.hxx
+
+DB_LIBS = \
+ libdb_plugins.a
+
# archive plugins
if ENABLE_ARCHIVE