aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-10-26 13:36:25 +0200
committerMax Kellermann <max@duempel.org>2013-10-26 13:49:15 +0200
commitde862f9f1bb72bd624cf4f341d03584a4123a6cb (patch)
tree7c63b0b4283a19d28e6f9e167367328ff37a7e73 /Makefile.am
parentb5e31c89c0217d89129cb4e6e1a1f4e5ef181b78 (diff)
downloadmpd-de862f9f1bb72bd624cf4f341d03584a4123a6cb.tar.gz
mpd-de862f9f1bb72bd624cf4f341d03584a4123a6cb.tar.xz
mpd-de862f9f1bb72bd624cf4f341d03584a4123a6cb.zip
test/test_mixramp: unit test for mixramp_interpolate()
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index dea7bdb56..48a143f39 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1058,6 +1058,7 @@ if ENABLE_TEST
C_TESTS = \
test/test_util \
test/test_byte_reverse \
+ test/test_mixramp \
test/test_pcm \
test/test_queue_priority
@@ -1483,6 +1484,15 @@ test_test_byte_reverse_LDADD = \
libutil.a \
$(CPPUNIT_LIBS)
+test_test_mixramp_SOURCES = \
+ src/Log.cxx \
+ test/test_mixramp.cxx
+test_test_mixramp_CPPFLAGS = $(AM_CPPFLAGS) $(CPPUNIT_CFLAGS) -DCPPUNIT_HAVE_RTTI=0
+test_test_mixramp_CXXFLAGS = $(AM_CXXFLAGS) -Wno-error=deprecated-declarations
+test_test_mixramp_LDADD = \
+ $(GLIB_LIBS) \
+ $(CPPUNIT_LIBS)
+
test_test_pcm_SOURCES = \
test/test_pcm_util.hxx \
test/test_pcm_dither.cxx \