aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-01-09 11:57:47 +0100
committerMax Kellermann <max@duempel.org>2014-01-09 12:19:52 +0100
commitdd82370a80c25322823bade6c9c76845b51eaa71 (patch)
tree53a51c12ba54a647022d6ef0cd82829fa7ef2891 /Makefile.am
parentdab052e53d91d7a54d557fb1d8fd762def4e1214 (diff)
downloadmpd-dd82370a80c25322823bade6c9c76845b51eaa71.tar.gz
mpd-dd82370a80c25322823bade6c9c76845b51eaa71.tar.xz
mpd-dd82370a80c25322823bade6c9c76845b51eaa71.zip
playlist/{asx,rss,xspf}: use Expat instead of GLib to parse XML
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index a63c9d1d7..7db87fd98 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1016,11 +1016,13 @@ libplaylist_plugins_a_SOURCES = \
src/playlist/EmbeddedCuePlaylistPlugin.hxx \
src/PlaylistRegistry.cxx src/PlaylistRegistry.hxx
libplaylist_plugins_a_CPPFLAGS = $(AM_CPPFLAGS) \
+ $(EXPAT_CFLAGS) \
$(YAJL_CFLAGS) \
$(patsubst -I%/FLAC,-I%,$(FLAC_CFLAGS))
PLAYLIST_LIBS = \
libplaylist_plugins.a \
+ $(EXPAT_LIBS) \
$(FLAC_LIBS)
if ENABLE_DESPOTIFY
@@ -1036,10 +1038,9 @@ libplaylist_plugins_a_SOURCES += \
PLAYLIST_LIBS += $(YAJL_LIBS)
endif
-if HAVE_GLIB
+if HAVE_EXPAT
libplaylist_plugins_a_SOURCES += \
- src/playlist/PlsPlaylistPlugin.cxx \
- src/playlist/PlsPlaylistPlugin.hxx \
+ src/Expat.cxx src/Expat.hxx \
src/playlist/XspfPlaylistPlugin.cxx \
src/playlist/XspfPlaylistPlugin.hxx \
src/playlist/AsxPlaylistPlugin.cxx \
@@ -1048,6 +1049,12 @@ libplaylist_plugins_a_SOURCES += \
src/playlist/RssPlaylistPlugin.hxx
endif
+if HAVE_GLIB
+libplaylist_plugins_a_SOURCES += \
+ src/playlist/PlsPlaylistPlugin.cxx \
+ src/playlist/PlsPlaylistPlugin.hxx
+endif
+
#
# Filter plugins
#