aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-01-20 21:31:40 +0100
committerMax Kellermann <max@duempel.org>2014-01-21 00:28:34 +0100
commitdd20a3ce7e5d6bb3efd41a2c9ab5ba27e8e15248 (patch)
tree7512a952fd46640fcbe60cbe00cb6bc249daf009 /Makefile.am
parentc727c86245ddbf1052023c3dba82b2020836e4ff (diff)
downloadmpd-dd20a3ce7e5d6bb3efd41a2c9ab5ba27e8e15248.tar.gz
mpd-dd20a3ce7e5d6bb3efd41a2c9ab5ba27e8e15248.tar.xz
mpd-dd20a3ce7e5d6bb3efd41a2c9ab5ba27e8e15248.zip
test: add unit test for playlist_check_translate_song()
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 882fd4e05..b70999b5c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1154,6 +1154,7 @@ C_TESTS = \
test/test_byte_reverse \
test/test_mixramp \
test/test_pcm \
+ test/test_translate_song \
test/test_queue_priority
if ENABLE_ARCHIVE
@@ -1625,6 +1626,21 @@ test_test_archive_LDADD = \
$(GLIB_LIBS) \
$(CPPUNIT_LIBS)
+test_test_translate_song_SOURCES = \
+ src/PlaylistSong.cxx \
+ src/DetachedSong.cxx \
+ src/Log.cxx \
+ test/test_translate_song.cxx
+test_test_translate_song_CPPFLAGS = $(AM_CPPFLAGS) $(CPPUNIT_CFLAGS) -DCPPUNIT_HAVE_RTTI=0
+test_test_translate_song_CXXFLAGS = $(AM_CXXFLAGS) -Wno-error=deprecated-declarations
+test_test_translate_song_LDADD = \
+ libtag.a \
+ libfs.a \
+ libsystem.a \
+ libutil.a \
+ $(GLIB_LIBS) \
+ $(CPPUNIT_LIBS)
+
test_test_queue_priority_SOURCES = \
src/Queue.cxx \
test/test_queue_priority.cxx