aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDenis Krjuchkov <denis@crazydev.net>2013-11-24 17:19:51 +0600
committerDenis Krjuchkov <denis@crazydev.net>2013-11-24 17:29:05 +0600
commitdb238cc23f3bb5c9768d30ae24b99e67a5795203 (patch)
treef6088e9948cfd7cdcf7f0a09c827ac46b9834dfb /Makefile.am
parent75e9c798e0aaf182d8d4ffc311c8d1ed0206bc2d (diff)
downloadmpd-db238cc23f3bb5c9768d30ae24b99e67a5795203.tar.gz
mpd-db238cc23f3bb5c9768d30ae24b99e67a5795203.tar.xz
mpd-db238cc23f3bb5c9768d30ae24b99e67a5795203.zip
CommandLine: new command line parser
This implementation behaves mostly identical to old parser. Few observable differences: - There are no option groups (single group is used for all options) - Option --stdout is hidden (it has been obsolete for a long time) - MPD executable name (mpd) is hardcoded for simplicity
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7240cb3f1..f7ce9e377 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -265,6 +265,8 @@ libutil_a_SOURCES = \
src/util/SliceBuffer.hxx \
src/util/HugeAllocator.cxx src/util/HugeAllocator.hxx \
src/util/PeakBuffer.cxx src/util/PeakBuffer.hxx \
+ src/util/OptionParser.cxx OptionParser.hxx \
+ src/util/OptionDef.hxx \
src/util/list.h \
src/util/list_sort.c src/util/list_sort.h \
src/util/ByteReverse.cxx src/util/ByteReverse.hxx \