aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-01-26 15:41:25 +0100
committerMax Kellermann <max@duempel.org>2014-01-26 15:43:23 +0100
commitd7e78059b02c79ba59eb4a687496a64060246a30 (patch)
tree8210ff1677c47dba1a1595ee6e0b63407c983cf4 /Makefile.am
parent01f7abfc6385884251cc57fa615a065f82d274df (diff)
downloadmpd-d7e78059b02c79ba59eb4a687496a64060246a30.tar.gz
mpd-d7e78059b02c79ba59eb4a687496a64060246a30.tar.xz
mpd-d7e78059b02c79ba59eb4a687496a64060246a30.zip
upnp: initialize the client handle only once
Eliminate class LibUPnP and move the code to ClientInit.cxx. Its initialization function can be called multiple times, but UpnpRegisterClient() is called at most once.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ebba8846f..0acca6b31 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -218,13 +218,13 @@ src_mpd_SOURCES = \
UPNP_SOURCES = \
src/lib/upnp/Init.cxx src/lib/upnp/Init.hxx \
+ src/lib/upnp/ClientInit.cxx src/lib/upnp/ClientInit.hxx \
src/lib/upnp/Device.cxx src/lib/upnp/Device.hxx \
src/lib/upnp/ContentDirectoryService.cxx src/lib/upnp/ContentDirectoryService.hxx \
src/lib/upnp/Discovery.cxx src/lib/upnp/Discovery.hxx \
src/lib/upnp/Domain.cxx src/lib/upnp/Domain.hxx \
src/lib/upnp/ixmlwrap.cxx src/lib/upnp/ixmlwrap.hxx \
src/lib/upnp/Callback.hxx \
- src/lib/upnp/upnpplib.cxx src/lib/upnp/upnpplib.hxx \
src/lib/upnp/Util.cxx src/lib/upnp/Util.hxx \
src/lib/upnp/WorkQueue.hxx \
src/lib/upnp/Action.hxx