aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2012-10-01 20:15:15 +0200
committerMax Kellermann <max@duempel.org>2012-10-02 00:45:24 +0200
commitd793b7c03ff7444b0aab485e5895573b4a4ff0a1 (patch)
tree94d3bc20c57b90045ea67bfb866f42ae671f6b24 /Makefile.am
parent9a715267ad1a86de4c522ff6ed5fd11827132c77 (diff)
downloadmpd-d793b7c03ff7444b0aab485e5895573b4a4ff0a1.tar.gz
mpd-d793b7c03ff7444b0aab485e5895573b4a4ff0a1.tar.xz
mpd-d793b7c03ff7444b0aab485e5895573b4a4ff0a1.zip
encoder/opus: new encoder plugin for the Opus codec
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 469ac5330..f5fb2148f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -684,6 +684,7 @@ libencoder_plugins_a_CPPFLAGS = $(AM_CPPFLAGS) \
$(LAME_CFLAGS) \
$(TWOLAME_CFLAGS) \
$(patsubst -I%/FLAC,-I%,$(FLAC_CFLAGS)) \
+ $(OPUS_CFLAGS) \
$(VORBISENC_CFLAGS)
ENCODER_LIBS = \
@@ -691,6 +692,7 @@ ENCODER_LIBS = \
$(LAME_LIBS) \
$(TWOLAME_LIBS) \
$(FLAC_LIBS) \
+ $(OPUS_LIBS) \
$(VORBISENC_LIBS)
libencoder_plugins_a_SOURCES =
@@ -708,6 +710,12 @@ libencoder_plugins_a_SOURCES += \
src/encoder/VorbisEncoderPlugin.hxx
endif
+if HAVE_OPUS
+libencoder_plugins_a_SOURCES += \
+ src/encoder/OpusEncoderPlugin.cxx \
+ src/encoder/OpusEncoderPlugin.hxx
+endif
+
if ENABLE_LAME_ENCODER
libencoder_plugins_a_SOURCES += src/encoder/lame_encoder.c
endif