aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-12-15 12:32:15 +0100
committerMax Kellermann <max@duempel.org>2013-12-15 18:43:12 +0100
commitd5dfe7d457b559bd9c53d65d0315c55611cc6a79 (patch)
tree42825c13cc44e4fe1272d14f9dc26f03ce0ef596 /Makefile.am
parent0db0b4e302f82165b763da7717059911a85c370f (diff)
downloadmpd-d5dfe7d457b559bd9c53d65d0315c55611cc6a79.tar.gz
mpd-d5dfe7d457b559bd9c53d65d0315c55611cc6a79.tar.xz
mpd-d5dfe7d457b559bd9c53d65d0315c55611cc6a79.zip
configure.ac: add option "--disable-glib"
Allows building without GLib. This fails to compile currently, because GLib is still used in the MPD core.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 12 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 6ce95d034..11ae26960 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -990,14 +990,6 @@ libplaylist_plugins_a_SOURCES = \
src/playlist/ExtM3uPlaylistPlugin.hxx \
src/playlist/M3uPlaylistPlugin.cxx \
src/playlist/M3uPlaylistPlugin.hxx \
- src/playlist/PlsPlaylistPlugin.cxx \
- src/playlist/PlsPlaylistPlugin.hxx \
- src/playlist/XspfPlaylistPlugin.cxx \
- src/playlist/XspfPlaylistPlugin.hxx \
- src/playlist/AsxPlaylistPlugin.cxx \
- src/playlist/AsxPlaylistPlugin.hxx \
- src/playlist/RssPlaylistPlugin.cxx \
- src/playlist/RssPlaylistPlugin.hxx \
src/playlist/CuePlaylistPlugin.cxx \
src/playlist/CuePlaylistPlugin.hxx \
src/playlist/EmbeddedCuePlaylistPlugin.cxx \
@@ -1024,6 +1016,18 @@ libplaylist_plugins_a_SOURCES += \
PLAYLIST_LIBS += $(YAJL_LIBS)
endif
+if HAVE_GLIB
+libplaylist_plugins_a_SOURCES += \
+ src/playlist/PlsPlaylistPlugin.cxx \
+ src/playlist/PlsPlaylistPlugin.hxx \
+ src/playlist/XspfPlaylistPlugin.cxx \
+ src/playlist/XspfPlaylistPlugin.hxx \
+ src/playlist/AsxPlaylistPlugin.cxx \
+ src/playlist/AsxPlaylistPlugin.hxx \
+ src/playlist/RssPlaylistPlugin.cxx \
+ src/playlist/RssPlaylistPlugin.hxx
+endif
+
#
# Filter plugins
#