aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-05-22 11:24:40 +0200
committerMax Kellermann <max@duempel.org>2014-05-22 12:35:20 +0200
commitcc6f1020d01a6f8f814a6a6a211a00d490459f66 (patch)
treec54861d8c84ebc5accddefadbd1f2aba67ee7cb5 /Makefile.am
parent316ddc2382c8060e8a1604752ec5accbb6fd35e4 (diff)
downloadmpd-cc6f1020d01a6f8f814a6a6a211a00d490459f66.tar.gz
mpd-cc6f1020d01a6f8f814a6a6a211a00d490459f66.tar.xz
mpd-cc6f1020d01a6f8f814a6a6a211a00d490459f66.zip
test/run_decoder: merge code into FakeDecoderAPI.cxx
Eliminate duplicate code.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 2dcc2c590..913d4bddd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1598,13 +1598,13 @@ test_dump_playlist_LDADD = \
libpcm.a \
$(GLIB_LIBS)
test_dump_playlist_SOURCES = test/dump_playlist.cxx \
- test/FakeDecoderAPI.cxx \
+ test/FakeDecoderAPI.cxx test/FakeDecoderAPI.hxx \
$(DECODER_SRC) \
src/Log.cxx src/LogBackend.cxx \
src/IOThread.cxx \
src/TagSave.cxx \
src/TagFile.cxx \
- src/CheckAudioFormat.cxx \
+ src/AudioFormat.cxx src/CheckAudioFormat.cxx \
src/DetachedSong.cxx
if HAVE_FLAC
@@ -1627,6 +1627,7 @@ test_run_decoder_LDADD = \
libutil.a \
$(GLIB_LIBS)
test_run_decoder_SOURCES = test/run_decoder.cxx \
+ test/FakeDecoderAPI.cxx test/FakeDecoderAPI.hxx \
test/stdbin.h \
src/Log.cxx src/LogBackend.cxx \
src/IOThread.cxx \
@@ -1651,11 +1652,11 @@ test_read_tags_LDADD = \
libutil.a \
$(GLIB_LIBS)
test_read_tags_SOURCES = test/read_tags.cxx \
- test/FakeDecoderAPI.cxx \
+ test/FakeDecoderAPI.cxx test/FakeDecoderAPI.hxx \
src/Log.cxx src/LogBackend.cxx \
src/IOThread.cxx \
src/ReplayGainInfo.cxx \
- src/CheckAudioFormat.cxx \
+ src/AudioFormat.cxx src/CheckAudioFormat.cxx \
$(DECODER_SRC)
if HAVE_ID3TAG