aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-07-30 22:26:24 +0200
committerMax Kellermann <max@duempel.org>2014-08-06 16:35:10 +0200
commitc9a71a7176f13cbd86c8270c523c0e506b2ab424 (patch)
tree1bc505fe58a10f2ddcd9fc4fa6671919eeeeba4d /Makefile.am
parent7ed8833fd567da2b0583365b1790ff61cd10cfd5 (diff)
downloadmpd-c9a71a7176f13cbd86c8270c523c0e506b2ab424.tar.gz
mpd-c9a71a7176f13cbd86c8270c523c0e506b2ab424.tar.xz
mpd-c9a71a7176f13cbd86c8270c523c0e506b2ab424.zip
fs/GzipOutputStream: new class wrapping zlib
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c69b33020..cb85dd5ae 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -521,6 +521,13 @@ libfs_a_SOURCES = \
src/fs/StandardDirectory.cxx src/fs/StandardDirectory.hxx \
src/fs/CheckFile.cxx src/fs/CheckFile.hxx \
src/fs/DirectoryReader.hxx
+libfs_a_CPPFLAGS = $(AM_CPPFLAGS) $(ZLIB_CFLAGS)
+
+if HAVE_ZLIB
+libfs_a_SOURCES += \
+ src/fs/output/GzipOutputStream.cxx src/fs/output/GzipOutputStream.hxx
+FS_LIBS += $(ZLIB_LIBS)
+endif
# Storage library
@@ -1596,6 +1603,16 @@ test_visit_archive_SOURCES = test/visit_archive.cxx \
endif
+if HAVE_ZLIB
+
+noinst_PROGRAMS += test/run_gzip
+test_run_gzip_LDADD = \
+ libutil.a \
+ $(FS_LIBS)
+test_run_gzip_SOURCES = test/run_gzip.cxx
+
+endif
+
test_dump_text_file_LDADD = \
$(INPUT_LIBS) \
$(ARCHIVE_LIBS) \