aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2012-08-07 20:08:50 +0200
committerMax Kellermann <max@duempel.org>2012-08-07 20:21:10 +0200
commitc6a0f5d3f9d70b890dfdc3ae0474dbcf72fe0499 (patch)
tree129297b51d15086571d509a2dfb7fb353858fa07 /Makefile.am
parentbb75e3ea553f2d577548430e2e99423ee74850ca (diff)
downloadmpd-c6a0f5d3f9d70b890dfdc3ae0474dbcf72fe0499.tar.gz
mpd-c6a0f5d3f9d70b890dfdc3ae0474dbcf72fe0499.tar.xz
mpd-c6a0f5d3f9d70b890dfdc3ae0474dbcf72fe0499.zip
test/DumpDatabase: new debug program
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6322e2f52..d5f3b318b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1010,6 +1010,7 @@ noinst_PROGRAMS = \
$(C_TESTS) \
test/read_conf \
test/run_resolver \
+ test/DumpDatabase \
test/run_input \
test/dump_text_file \
test/dump_playlist \
@@ -1040,6 +1041,21 @@ test_run_resolver_LDADD = \
test_run_resolver_SOURCES = test/run_resolver.c \
src/resolver.c
+test_DumpDatabase_LDADD = \
+ libdb_plugins.a \
+ libutil.a \
+ $(GLIB_LIBS)
+test_DumpDatabase_SOURCES = test/DumpDatabase.cxx \
+ src/DatabaseRegistry.cxx \
+ src/Directory.cxx src/directory_save.c \
+ src/playlist_vector.c src/playlist_database.c \
+ src/db_lock.c src/db_save.c \
+ src/song.c src/song_sort.c src/song_save.c \
+ src/tag.c src/tag_pool.c src/tag_save.c \
+ src/path.c \
+ src/text_file.c \
+ src/conf.c src/tokenizer.c src/utils.c src/string_util.c
+
test_run_input_LDADD = \
$(INPUT_LIBS) \
$(ARCHIVE_LIBS) \