aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-01-29 20:16:43 +0100
committerMax Kellermann <max@duempel.org>2014-01-30 18:47:05 +0100
commitc6725884bc155da431889468c86c546f0f64f9a1 (patch)
tree61d89751ecc98db9600620ac1788f32dea9214e1 /Makefile.am
parenta31738f6f1473f4f621bc16513ed0c6024749389 (diff)
downloadmpd-c6725884bc155da431889468c86c546f0f64f9a1.tar.gz
mpd-c6725884bc155da431889468c86c546f0f64f9a1.tar.xz
mpd-c6725884bc155da431889468c86c546f0f64f9a1.zip
db/update: convert to OO API
Move global variables into the new classes. That may allow multiple update threads for multiple databases one day.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 9 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index c51a12e6b..a8850ce29 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -124,15 +124,15 @@ src_mpd_SOURCES = \
src/filter/FilterInternal.hxx \
src/filter/FilterRegistry.cxx src/filter/FilterRegistry.hxx \
src/db/update/UpdateDomain.cxx src/db/update/UpdateDomain.hxx \
- src/db/update/UpdateGlue.cxx src/db/update/UpdateGlue.hxx \
- src/db/update/UpdateQueue.cxx src/db/update/UpdateQueue.hxx \
+ src/db/update/Service.cxx src/db/update/Service.hxx \
+ src/db/update/UpdateGlue.cxx \
+ src/db/update/Queue.cxx src/db/update/Queue.hxx \
src/db/update/UpdateIO.cxx src/db/update/UpdateIO.hxx \
- src/db/update/UpdateDatabase.cxx src/db/update/UpdateDatabase.hxx \
- src/db/update/UpdateWalk.cxx src/db/update/UpdateWalk.hxx \
- src/db/update/UpdateSong.cxx src/db/update/UpdateSong.hxx \
- src/db/update/UpdateContainer.cxx src/db/update/UpdateContainer.hxx \
- src/db/update/UpdateInternal.hxx \
- src/db/update/UpdateRemove.cxx src/db/update/UpdateRemove.hxx \
+ src/db/update/Editor.cxx src/db/update/Editor.hxx \
+ src/db/update/Walk.cxx src/db/update/Walk.hxx \
+ src/db/update/UpdateSong.cxx \
+ src/db/update/Container.cxx \
+ src/db/update/Remove.cxx src/db/update/Remove.hxx \
src/db/update/ExcludeList.cxx src/db/update/ExcludeList.hxx \
src/client/Client.cxx src/client/Client.hxx \
src/client/ClientInternal.hxx \
@@ -486,7 +486,7 @@ if ENABLE_ARCHIVE
noinst_LIBRARIES += libarchive.a
src_mpd_SOURCES += \
- src/db/update/UpdateArchive.cxx src/db/update/UpdateArchive.hxx
+ src/db/update/Archive.cxx
libarchive_a_SOURCES = \
src/archive/ArchiveDomain.cxx src/archive/ArchiveDomain.hxx \