aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-10-23 21:29:37 +0200
committerMax Kellermann <max@duempel.org>2013-10-23 21:58:44 +0200
commitc3e720279c89a56b9bbdc46cc6d8c02aefb10ed4 (patch)
tree1d0647b3c8a05cfca3844293e144896f8f82d480 /Makefile.am
parentf1027ed198535ce16cfb9c83ac802788ec750488 (diff)
downloadmpd-c3e720279c89a56b9bbdc46cc6d8c02aefb10ed4.tar.gz
mpd-c3e720279c89a56b9bbdc46cc6d8c02aefb10ed4.tar.xz
mpd-c3e720279c89a56b9bbdc46cc6d8c02aefb10ed4.zip
test/test_util: unit test for libutil.a
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b3f62b6f7..1bacdcdbd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1056,6 +1056,7 @@ sparse-check:
if ENABLE_TEST
C_TESTS = \
+ test/test_util \
test/test_byte_reverse \
test/test_pcm \
test/test_queue_priority
@@ -1466,6 +1467,15 @@ test_run_inotify_LDADD = \
$(GLIB_LIBS)
endif
+test_test_util_SOURCES = \
+ test/test_util.cxx
+test_test_util_CPPFLAGS = $(AM_CPPFLAGS) $(CPPUNIT_CFLAGS) -DCPPUNIT_HAVE_RTTI=0
+test_test_util_CXXFLAGS = $(AM_CXXFLAGS) -Wno-error=deprecated-declarations
+test_test_util_LDADD = \
+ libutil.a \
+ $(GLIB_LIBS) \
+ $(CPPUNIT_LIBS)
+
test_test_byte_reverse_SOURCES = \
test/test_byte_reverse.cxx
test_test_byte_reverse_CPPFLAGS = $(AM_CPPFLAGS) $(CPPUNIT_CFLAGS) -DCPPUNIT_HAVE_RTTI=0