aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-08-26 20:08:13 +0200
committerMax Kellermann <max@duempel.org>2009-08-26 20:08:13 +0200
commitbff4c54ece5d6ebf84c1a19a05afbeba57bf65ae (patch)
tree31faabe85d032cf3e5d21f54fdbb8469e3ab6e46 /Makefile.am
parentdf0c26a394be7dd4137c9614dd867122019d78f8 (diff)
downloadmpd-bff4c54ece5d6ebf84c1a19a05afbeba57bf65ae.tar.gz
mpd-bff4c54ece5d6ebf84c1a19a05afbeba57bf65ae.tar.xz
mpd-bff4c54ece5d6ebf84c1a19a05afbeba57bf65ae.zip
decoder/mpg123: new decoder plugin based on libmpg123
Still missing: - seeking - tags - streaming - encodings other than MPG123_ENC_SIGNED_16
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8e1341f0f..b017d970a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -348,6 +348,7 @@ DECODER_CFLAGS = \
$(WILDMIDI_CFLAGS) \
$(WAVPACK_CFLAGS) \
$(MAD_CFLAGS) \
+ $(MPG123_CFLAGS) \
$(FFMPEG_CFLAGS) \
$(CUE_CFLAGS)
@@ -362,6 +363,7 @@ DECODER_LIBS = \
$(WILDMIDI_LIBS) \
$(WAVPACK_LIBS) \
$(MAD_LIBS) \
+ $(MPG123_LIBS) \
$(MP4FF_LIBS) \
$(FFMPEG_LIBS) \
$(CUE_LIBS)
@@ -374,6 +376,10 @@ if HAVE_MAD
DECODER_SRC += src/decoder/mad_plugin.c
endif
+if HAVE_MPG123
+DECODER_SRC += src/decoder/mpg123_decoder_plugin.c
+endif
+
if HAVE_MPCDEC
DECODER_SRC += src/decoder/mpcdec_plugin.c
endif