aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-03-01 01:26:04 +0100
committerMax Kellermann <max@duempel.org>2009-03-01 01:26:04 +0100
commitb4f84fab349525aa5a4ea364509a4d9ec9db47f4 (patch)
tree485413d82608295e1b9fb27fccc6c2c58159a122 /Makefile.am
parentc4626143c91602cd89e47160e92e9e19db331f65 (diff)
downloadmpd-b4f84fab349525aa5a4ea364509a4d9ec9db47f4.tar.gz
mpd-b4f84fab349525aa5a4ea364509a4d9ec9db47f4.tar.xz
mpd-b4f84fab349525aa5a4ea364509a4d9ec9db47f4.zip
configure.ac: make "xmlto" optional
Even when --enable-documentation is passed, don't abort if "xmlto" was not found.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 12 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 8dae19bad..6d72b3051 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -569,9 +569,6 @@ endif
# Documentation
#
-DOCBOOK_FILES = doc/protocol.xml
-DOCBOOK_HTML = $(patsubst %.xml,%/index.html,$(DOCBOOK_FILES))
-
man_MANS = doc/mpd.1 doc/mpd.conf.5
doc_DATA = AUTHORS COPYING NEWS README TODO UPGRADING doc/mpdconf.example
@@ -579,12 +576,24 @@ if ENABLE_DOCUMENTATION
protocoldir = $(docdir)/protocol
protocol_DATA = $(wildcard doc/protocol/*.html)
+if HAVE_XMLTO
+
+DOCBOOK_FILES = doc/protocol.xml
+DOCBOOK_HTML = $(patsubst %.xml,%/index.html,$(DOCBOOK_FILES))
+
$(DOCBOOK_HTML): %/index.html: %.xml
$(XMLTO) -o $(@D) --stringparam chunker.output.encoding=utf-8 html $<
doc/api/html/index.html: doc/doxygen.conf
$(DOXYGEN) $<
+else
+
+DOCBOOK_FILES =
+DOCBOOK_HTML =
+
+endif
+
all-local: $(DOCBOOK_HTML) doc/api/html/index.html
clean-local: