aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-02-08 14:03:25 +0100
committerMax Kellermann <max@duempel.org>2014-02-08 14:24:47 +0100
commitb3663b5da2ebcd87f0b1cb498ddd9ea7aff6eeb5 (patch)
treecf0caf1f038c49575d1942033ede3f812f994c50 /Makefile.am
parentd761d8b168bb245ab382b93142a8f9595bbb6404 (diff)
downloadmpd-b3663b5da2ebcd87f0b1cb498ddd9ea7aff6eeb5.tar.gz
mpd-b3663b5da2ebcd87f0b1cb498ddd9ea7aff6eeb5.tar.xz
mpd-b3663b5da2ebcd87f0b1cb498ddd9ea7aff6eeb5.zip
storage/nfs: new storage plugin
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 53d596247..b487d019d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -432,6 +432,7 @@ libstorage_a_SOURCES = \
src/storage/FileInfo.hxx
libstorage_a_CPPFLAGS = $(AM_CPPFLAGS) \
+ $(NFS_CFLAGS) \
$(SMBCLIENT_CFLAGS)
STORAGE_LIBS = libstorage.a
@@ -442,6 +443,12 @@ libstorage_a_SOURCES += \
src/storage/plugins/SmbclientStorage.cxx src/neighbor/plugins/SmbclientStorage.hxx
endif
+if ENABLE_NFS
+libstorage_a_SOURCES += \
+ src/lib/nfs/Domain.cxx src/lib/nfs/Domain.hxx \
+ src/storage/plugins/NfsStorage.cxx src/neighbor/plugins/NfsStorage.hxx
+endif
+
endif
# neighbor plugins