aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-02-21 10:35:20 +0100
committerMax Kellermann <max@duempel.org>2014-02-21 10:51:07 +0100
commitadb89e012149157203813577f43306240072f070 (patch)
treef0ce090f3d6e9242fe52006d47506db09db24574 /Makefile.am
parentb7a795375716b832db60e95ecd2fb0aae75c1a0f (diff)
downloadmpd-adb89e012149157203813577f43306240072f070.tar.gz
mpd-adb89e012149157203813577f43306240072f070.tar.xz
mpd-adb89e012149157203813577f43306240072f070.zip
Makefile.am: build shared library for Android
Doesn't work yet, just to get the Android port started.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 44d70411e..9993b9ffa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -229,6 +229,16 @@ UPNP_SOURCES = \
src/lib/upnp/Action.hxx
#
+# Android native library
+#
+
+if ANDROID
+all-local: libmpd.so
+libmpd.so: $(filter %.a,$(src_mpd_LDADD))
+ $(AM_V_CXXLD)$(CXXLD) -Wl,-shared -o $@ $(AM_CXXFLAGS) $(CXXFLAGS) $(LDFLAGS) $(src_mpd_LDADD) $(LIBS)
+endif
+
+#
# Windows resource file
#