aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2015-01-26 09:55:31 +0100
committerMax Kellermann <max@duempel.org>2015-01-26 09:55:31 +0100
commitad1b6ef0ac5e7c869b6adbede153e8b2ac55d708 (patch)
tree026f67796374ac9e9c71e6d812148bf463d8c26c /Makefile.am
parented5c6be2f1c3fa492b3642682dd2363dbc1027df (diff)
downloadmpd-ad1b6ef0ac5e7c869b6adbede153e8b2ac55d708.tar.gz
mpd-ad1b6ef0ac5e7c869b6adbede153e8b2ac55d708.tar.xz
mpd-ad1b6ef0ac5e7c869b6adbede153e8b2ac55d708.zip
{playlist,input}/despotify: remove defunct plugin
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am31
1 files changed, 0 insertions, 31 deletions
diff --git a/Makefile.am b/Makefile.am
index a96d69369..b30f8d915 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -221,11 +221,6 @@ EXTRA_src_mpd_DEPENDENCIES = src/win32/mpd_win32_rc.$(OBJEXT)
src_mpd_LDFLAGS = -Wl,src/win32/mpd_win32_rc.$(OBJEXT)
endif
-if ENABLE_DESPOTIFY
-src_mpd_SOURCES += \
- src/DespotifyUtils.cxx src/DespotifyUtils.hxx
-endif
-
if ENABLE_INOTIFY
src_mpd_SOURCES += \
src/InotifyDomain.cxx src/InotifyDomain.hxx \
@@ -770,7 +765,6 @@ libinput_a_CPPFLAGS = $(AM_CPPFLAGS) \
$(CURL_CFLAGS) \
$(CDIO_PARANOIA_CFLAGS) \
$(FFMPEG_CFLAGS) \
- $(DESPOTIFY_CFLAGS) \
$(MMS_CFLAGS)
INPUT_LIBS = \
@@ -778,7 +772,6 @@ INPUT_LIBS = \
$(CURL_LIBS) \
$(CDIO_PARANOIA_LIBS) \
$(FFMPEG_LIBS) \
- $(DESPOTIFY_LIBS) \
$(MMS_LIBS)
if ENABLE_CURL
@@ -803,12 +796,6 @@ libinput_a_SOURCES += \
src/input/MmsInputPlugin.cxx src/input/MmsInputPlugin.hxx
endif
-if ENABLE_DESPOTIFY
-libinput_a_SOURCES += \
- src/input/DespotifyInputPlugin.cxx \
- src/input/DespotifyInputPlugin.hxx
-endif
-
liboutput_plugins_a_CPPFLAGS = $(AM_CPPFLAGS) \
$(AO_CFLAGS) \
@@ -989,12 +976,6 @@ PLAYLIST_LIBS = \
libplaylist_plugins.a \
$(FLAC_LIBS)
-if ENABLE_DESPOTIFY
-libplaylist_plugins_a_SOURCES += \
- src/playlist/DespotifyPlaylistPlugin.cxx \
- src/playlist/DespotifyPlaylistPlugin.hxx
-endif
-
if ENABLE_SOUNDCLOUD
libplaylist_plugins_a_SOURCES += \
src/playlist/SoundCloudPlaylistPlugin.cxx \
@@ -1185,10 +1166,6 @@ test_visit_archive_SOURCES = test/visit_archive.cxx \
src/IOThread.cxx \
src/InputStream.cxx
-if ENABLE_DESPOTIFY
-test_visit_archive_SOURCES += src/DespotifyUtils.cxx
-endif
-
endif
test_dump_text_file_LDADD = \
@@ -1313,14 +1290,6 @@ test_run_filter_SOURCES = test/run_filter.cxx \
src/ReplayGainInfo.cxx \
src/AudioCompress/compress.c
-if ENABLE_DESPOTIFY
-test_read_tags_SOURCES += src/DespotifyUtils.cxx
-test_run_input_SOURCES += src/DespotifyUtils.cxx
-test_dump_text_file_SOURCES += src/DespotifyUtils.cxx
-test_dump_playlist_SOURCES += src/DespotifyUtils.cxx
-test_run_decoder_SOURCES += src/DespotifyUtils.cxx
-endif
-
if ENABLE_ENCODER
noinst_PROGRAMS += test/run_encoder
test_run_encoder_SOURCES = test/run_encoder.cxx \