aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-10-17 18:57:22 +0200
committerMax Kellermann <max@duempel.org>2013-10-17 19:26:23 +0200
commitaad0ea6e23d285f9471bddfa5fb919bb984be993 (patch)
tree47386001e4f2621845d3dd4df0918b263d7b8931 /Makefile.am
parent05de2e998c7df2757ae63ce6a053e27eca3d13ca (diff)
downloadmpd-aad0ea6e23d285f9471bddfa5fb919bb984be993.tar.gz
mpd-aad0ea6e23d285f9471bddfa5fb919bb984be993.tar.xz
mpd-aad0ea6e23d285f9471bddfa5fb919bb984be993.zip
Makefile.am: move sources to libthread.a
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 15 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index 569f66d18..140514a9b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,6 +9,7 @@ bin_PROGRAMS = src/mpd
noinst_LIBRARIES = \
libutil.a \
+ libthread.a \
libsystem.a \
libevent.a \
libpcm.a \
@@ -44,6 +45,7 @@ src_mpd_LDADD = \
$(MIXER_LIBS) \
libconf.a \
libevent.a \
+ libthread.a \
libsystem.a \
libutil.a \
libfs.a \
@@ -69,15 +71,6 @@ src_mpd_SOURCES = \
$(OUTPUT_API_SRC) \
$(MIXER_API_SRC) \
src/Compiler.h \
- src/thread/Id.hxx \
- src/thread/Mutex.hxx \
- src/thread/PosixMutex.hxx \
- src/thread/CriticalSection.hxx \
- src/thread/GLibMutex.hxx \
- src/thread/Cond.hxx \
- src/thread/PosixCond.hxx \
- src/thread/WindowsCond.hxx \
- src/thread/GLibCond.hxx \
src/notify.cxx src/notify.hxx \
src/AudioConfig.cxx src/AudioConfig.hxx \
src/CheckAudioFormat.cxx src/CheckAudioFormat.hxx \
@@ -270,6 +263,19 @@ libutil_a_SOURCES = \
src/util/ByteReverse.cxx src/util/ByteReverse.hxx \
src/util/bit_reverse.c src/util/bit_reverse.h
+# Multi-threading library
+
+libthread_a_SOURCES = \
+ src/thread/Mutex.hxx \
+ src/thread/PosixMutex.hxx \
+ src/thread/CriticalSection.hxx \
+ src/thread/GLibMutex.hxx \
+ src/thread/Cond.hxx \
+ src/thread/PosixCond.hxx \
+ src/thread/WindowsCond.hxx \
+ src/thread/GLibCond.hxx \
+ src/thread/Id.hxx
+
# System library
libsystem_a_SOURCES = \