aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-08-07 18:54:06 +0200
committerMax Kellermann <max@duempel.org>2014-08-07 19:38:25 +0200
commitaa2e4d92e0005f4516eb591803120eff89f99109 (patch)
treebeb83ec24f0cb5b527ec60bd56c2722681f1d3f5 /Makefile.am
parent0ea66a1275da319e2443fa1536cec7ea7fc53b53 (diff)
downloadmpd-aa2e4d92e0005f4516eb591803120eff89f99109.tar.gz
mpd-aa2e4d92e0005f4516eb591803120eff89f99109.tar.xz
mpd-aa2e4d92e0005f4516eb591803120eff89f99109.zip
fs/io/BufferedReader: new class to replace class TextFile
The new class is pluggable, to prepare for gzipped database files. For now, the TextFile class remains, and will be refactored away later.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3491f2e6b..3ab492aae 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -508,6 +508,7 @@ FS_LIBS = libfs.a
libfs_a_SOURCES = \
src/fs/io/Reader.hxx \
src/fs/io/FileReader.cxx src/fs/io/FileReader.hxx \
+ src/fs/io/BufferedReader.cxx src/fs/io/BufferedReader.hxx \
src/fs/io/TextFile.cxx src/fs/io/TextFile.hxx \
src/fs/io/OutputStream.hxx \
src/fs/io/StdoutOutputStream.hxx \