aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-12-31 11:11:14 +0100
committerMax Kellermann <max@duempel.org>2009-12-31 15:50:59 +0100
commita0384aaead1427e9f7bd3643c4149371d687e53d (patch)
tree7a60322cedc1fb3af7c01ad773053ea2fe33f7a9 /Makefile.am
parentefc885a9dc2e6632ca2a24a0ff52ab51bb1d82d1 (diff)
downloadmpd-a0384aaead1427e9f7bd3643c4149371d687e53d.tar.gz
mpd-a0384aaead1427e9f7bd3643c4149371d687e53d.tar.xz
mpd-a0384aaead1427e9f7bd3643c4149371d687e53d.zip
Makefile.am: added unit tests for the archive plugins
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b703529a9..020a2aeec 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -755,6 +755,8 @@ sparse-check:
if ENABLE_TEST
+TESTS =
+
noinst_PROGRAMS = \
test/read_conf \
test/run_input \
@@ -974,6 +976,18 @@ test_read_mixer_SOURCES = test/read_mixer.c \
src/fd_util.c \
$(MIXER_SRC)
+if ENABLE_BZIP2_TEST
+TESTS += test/test_archive_bzip2.sh
+endif
+
+if ENABLE_ZZIP_TEST
+TESTS += test/test_archive_zzip.sh
+endif
+
+if ENABLE_ISO9660_TEST
+TESTS += test/test_archive_iso9660.sh
+endif
+
endif