aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorTony Miller <mcfiredrill@gmail.com>2010-04-10 01:05:16 -0700
committerTony Miller <mcfiredrill@gmail.com>2010-04-10 01:05:16 -0700
commit9d55b16998b6336bfdd6ea0ae3ac31f8685521f6 (patch)
treeeeaa9587fbc8727e76d7ced346ee9646ab00af86 /Makefile.am
parentc52f469c9cff4ad6aeede40ff3254d695a9ba603 (diff)
downloadmpd-9d55b16998b6336bfdd6ea0ae3ac31f8685521f6.tar.gz
mpd-9d55b16998b6336bfdd6ea0ae3ac31f8685521f6.tar.xz
mpd-9d55b16998b6336bfdd6ea0ae3ac31f8685521f6.zip
Decoder for game music emulation library.
Supports a number of videogame music formats, more info here: http://www.fly.net/~ant/libs/audio.html I wrote this plugin for the latest svn, get it here: http://code.google.com/p/game-music-emu/source/checkout
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index aa7b70997..86b0246fa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -411,6 +411,7 @@ DECODER_CFLAGS = \
$(AUDIOFILE_CFLAGS) \
$(LIBMIKMOD_CFLAGS) \
$(MODPLUG_CFLAGS) \
+ $(GME_CFLAGS) \
$(SIDPLAY_CFLAGS) \
$(FLUIDSYNTH_CFLAGS) \
$(WILDMIDI_CFLAGS) \
@@ -426,6 +427,7 @@ DECODER_LIBS = \
$(SNDFILE_LIBS) \
$(AUDIOFILE_LIBS) $(LIBMIKMOD_LIBS) \
$(MODPLUG_LIBS) \
+ $(GME_LIBS) \
$(SIDPLAY_LIBS) \
$(FLUIDSYNTH_LIBS) \
$(WILDMIDI_LIBS) \
@@ -520,6 +522,10 @@ if ENABLE_SNDFILE
DECODER_SRC += src/decoder/sndfile_decoder_plugin.c
endif
+if HAVE_GME
+DECODER_SRC += src/decoder/gme_decoder_plugin.c
+endif
+
# encoder plugins
ENCODER_CFLAGS = \