aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2010-12-21 22:23:01 +0100
committerMax Kellermann <max@duempel.org>2010-12-22 09:44:02 +0100
commit9bf7fde49f0883356a4fded05b3fe72db8d3686a (patch)
tree86ac3eae7ebdf1b818e40effcc7e84c51d8eab6c /Makefile.am
parent4783ebc918a2e09c99f7a74645937df2618574ab (diff)
downloadmpd-9bf7fde49f0883356a4fded05b3fe72db8d3686a.tar.gz
mpd-9bf7fde49f0883356a4fded05b3fe72db8d3686a.tar.xz
mpd-9bf7fde49f0883356a4fded05b3fe72db8d3686a.zip
configure.ac: hook the cdio_paranoia input plugin
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0966a2a66..f02b389c8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -106,6 +106,7 @@ mpd_headers = \
src/input/curl_input_plugin.h \
src/input/rewind_input_plugin.h \
src/input/mms_input_plugin.h \
+ src/input/cdio_paranoia_input_plugin.h \
src/text_file.h \
src/text_input_stream.h \
src/icy_server.h \
@@ -612,11 +613,13 @@ endif
INPUT_CFLAGS = \
$(CURL_CFLAGS) \
+ $(CDIO_PARANOIA_CFLAGS) \
$(FFMPEG_CFLAGS) \
$(MMS_CFLAGS)
INPUT_LIBS = \
$(CURL_LIBS) \
+ $(CDIO_PARANOIA_LIBS) \
$(FFMPEG_LIBS) \
$(MMS_LIBS)
@@ -632,6 +635,10 @@ INPUT_SRC += src/input/curl_input_plugin.c \
src/icy_metadata.c
endif
+if ENABLE_CDIO_PARANOIA
+INPUT_SRC += src/input/cdio_paranoia_input_plugin.c
+endif
+
if HAVE_FFMPEG
INPUT_SRC += src/input/ffmpeg_input_plugin.c
endif