aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-07-06 22:50:07 +0200
committerMax Kellermann <max@duempel.org>2009-07-06 22:50:07 +0200
commit971fbe5d8ed2c5437f47d0ad10b43163ee88a413 (patch)
treea9b3155a431b4328a6043c5cb2813a7f6465f5e4 /Makefile.am
parent45df3e5e548d1d1f7f128c54291168efd3669b52 (diff)
downloadmpd-971fbe5d8ed2c5437f47d0ad10b43163ee88a413.tar.gz
mpd-971fbe5d8ed2c5437f47d0ad10b43163ee88a413.tar.xz
mpd-971fbe5d8ed2c5437f47d0ad10b43163ee88a413.zip
Makefile.am: disable test/run_encoder without plugins
If the encoder plugin API is disabled at compile time, don't compile test/run_encoder.c.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d89aeb694..19658d77c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -624,7 +624,6 @@ noinst_PROGRAMS = \
test/run_decoder \
test/read_tags \
test/run_filter \
- test/run_encoder \
test/run_output \
test/read_mixer \
test/software_volume
@@ -705,6 +704,8 @@ if HAVE_LIBSAMPLERATE
test_run_filter_SOURCES += src/pcm_resample_libsamplerate.c
endif
+if ENABLE_ENCODER
+noinst_PROGRAMS += test/run_encoder
test_run_encoder_SOURCES = test/run_encoder.c \
src/conf.c src/buffer2array.c \
src/utils.c \
@@ -714,6 +715,7 @@ test_run_encoder_SOURCES = test/run_encoder.c \
test_run_encoder_LDADD = $(MPD_LIBS) \
$(ENCODER_LIBS) \
$(GLIB_LIBS)
+endif
test_software_volume_SOURCES = test/software_volume.c \
src/audio_parser.c \