aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-09-25 18:32:00 +0200
committerMax Kellermann <max@duempel.org>2009-09-25 18:32:00 +0200
commit8f261af5c1cfd6f922df009e17756fa3bef71458 (patch)
treedd5dd4bd6d41d1536e31f32e502e473e40520663 /Makefile.am
parent3e8bdb93844eb21f4a34d4f586e51f869933ebb8 (diff)
downloadmpd-8f261af5c1cfd6f922df009e17756fa3bef71458.tar.gz
mpd-8f261af5c1cfd6f922df009e17756fa3bef71458.tar.xz
mpd-8f261af5c1cfd6f922df009e17756fa3bef71458.zip
automatically update the database with Linux inotify
This patch implements a light-weight inotify library, and watches all directories below the music directory. It updates all directories where files changed after a delay of 5 seconds.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1fb3b8451..39c18a01f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -74,6 +74,9 @@ mpd_headers = \
src/fifo_buffer.h \
src/update.h \
src/update_internal.h \
+ src/inotify_source.h \
+ src/inotify_queue.h \
+ src/inotify_update.h \
src/dirvec.h \
src/gcc.h \
src/decoder_list.h \
@@ -275,6 +278,13 @@ src_mpd_SOURCES = \
src/stored_playlist.c \
src/timer.c
+if HAVE_INOTIFY
+src_mpd_SOURCES += \
+ src/inotify_source.c \
+ src/inotify_queue.c \
+ src/inotify_update.c
+endif
+
if ENABLE_SQLITE
src_mpd_SOURCES += \
src/sticker.c \