aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-12-22 23:26:52 +0100
committerMax Kellermann <max@duempel.org>2013-12-23 10:58:37 +0100
commit8edde7a4b3d652d0ac6ac3770369ddababe310a3 (patch)
tree3f0f59fd22e20853eed3e0ecee65a75fcef87155 /Makefile.am
parentd11a0c9f14dcabf9ddbf8e38379dc7d6d890b02b (diff)
downloadmpd-8edde7a4b3d652d0ac6ac3770369ddababe310a3.tar.gz
mpd-8edde7a4b3d652d0ac6ac3770369ddababe310a3.tar.xz
mpd-8edde7a4b3d652d0ac6ac3770369ddababe310a3.zip
pcm/Volume: convert to class
Prepare for adding state.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 767b4dcf2..0448cf416 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1397,7 +1397,7 @@ endif
test_software_volume_SOURCES = test/software_volume.cxx \
test/stdbin.h \
- src/CheckAudioFormat.cxx \
+ src/AudioFormat.cxx src/CheckAudioFormat.cxx \
src/AudioParser.cxx
test_software_volume_LDADD = \
$(PCM_LIBS) \
@@ -1484,6 +1484,7 @@ test_read_mixer_SOURCES = test/read_mixer.cxx \
src/Log.cxx src/LogBackend.cxx \
src/MixerControl.cxx \
src/FilterPlugin.cxx \
+ src/AudioFormat.cxx \
src/filter/VolumeFilterPlugin.cxx
if ENABLE_BZIP2_TEST
@@ -1538,6 +1539,7 @@ test_test_mixramp_LDADD = \
$(CPPUNIT_LIBS)
test_test_pcm_SOURCES = \
+ src/AudioFormat.cxx \
test/test_pcm_util.hxx \
test/test_pcm_dither.cxx \
test/test_pcm_pack.cxx \