aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2012-03-19 19:59:30 +0100
committerMax Kellermann <max@duempel.org>2012-03-19 20:37:25 +0100
commit8dcefaf2e3366510a78117ad651f1f1116f6ab83 (patch)
tree1fc742b9e611532828d16996afa73244fdf82925 /Makefile.am
parent48e3432a639e5d50b68014e03f2c995ce63d40e0 (diff)
downloadmpd-8dcefaf2e3366510a78117ad651f1f1116f6ab83.tar.gz
mpd-8dcefaf2e3366510a78117ad651f1f1116f6ab83.tar.xz
mpd-8dcefaf2e3366510a78117ad651f1f1116f6ab83.zip
test/dump_text_file: debug program for text_input_stream.c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 93e4dd499..fdb925a8d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -977,6 +977,7 @@ noinst_PROGRAMS = \
test/run_resolver \
test/run_tcp_connect \
test/run_input \
+ test/dump_text_file \
test/dump_playlist \
test/run_decoder \
test/read_tags \
@@ -1021,6 +1022,18 @@ test_run_input_SOURCES = test/run_input.c \
src/tag.c src/tag_pool.c src/tag_save.c \
src/fd_util.c
+test_dump_text_file_LDADD = \
+ $(INPUT_LIBS) \
+ $(ARCHIVE_LIBS) \
+ $(GLIB_LIBS)
+test_dump_text_file_SOURCES = test/dump_text_file.c \
+ test/stdbin.h \
+ src/io_thread.c src/io_thread.h \
+ src/conf.c src/tokenizer.c src/utils.c src/string_util.c\
+ src/tag.c src/tag_pool.c \
+ src/text_input_stream.c src/fifo_buffer.c \
+ src/fd_util.c
+
test_dump_playlist_LDADD = \
$(PLAYLIST_LIBS) \
$(FLAC_LIBS) \
@@ -1117,6 +1130,8 @@ test_read_tags_SOURCES += \
src/despotify_utils.c
test_run_input_SOURCES += \
src/despotify_utils.c
+test_dump_text_file_SOURCES += \
+ src/despotify_utils.c
test_dump_playlist_SOURCES += \
src/despotify_utils.c
test_run_decoder_SOURCES += \