aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-02-18 23:04:06 +0100
committerMax Kellermann <max@duempel.org>2014-02-18 23:10:53 +0100
commit8ae492dfebbaf26188bf49d264a2633b5041a37b (patch)
treeace4249dcc5dd857f052873a76ea15609246bb27 /Makefile.am
parente8789d7cb9b6a539b2aa738fbe60816ee0410334 (diff)
downloadmpd-8ae492dfebbaf26188bf49d264a2633b5041a37b.tar.gz
mpd-8ae492dfebbaf26188bf49d264a2633b5041a37b.tar.xz
mpd-8ae492dfebbaf26188bf49d264a2633b5041a37b.zip
Makefile.am: merge mpd_headers into src_mpd_SOURCES
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 8 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index ad9127cda..730468759 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -53,21 +53,13 @@ src_mpd_LDADD = \
$(SYSTEMD_DAEMON_LIBS) \
$(GLIB_LIBS)
-mpd_headers = \
- src/check.h \
- src/AudioCompress/config.h \
- src/AudioCompress/compress.h \
- src/open.h \
- src/Playlist.hxx \
- src/poison.h \
- src/TimePrint.cxx src/TimePrint.hxx \
- src/Timer.hxx
-
src_mpd_SOURCES = \
- $(mpd_headers) \
$(OUTPUT_API_SRC) \
$(MIXER_API_SRC) \
+ src/check.h \
src/Compiler.h \
+ src/open.h \
+ src/poison.h \
src/notify.cxx src/notify.hxx \
src/AudioConfig.cxx src/AudioConfig.hxx \
src/CheckAudioFormat.cxx src/CheckAudioFormat.hxx \
@@ -132,6 +124,8 @@ src_mpd_SOURCES = \
src/unix/SignalHandlers.cxx src/unix/SignalHandlers.hxx \
src/unix/Daemon.cxx src/unix/Daemon.hxx \
src/unix/PidFile.hxx \
+ src/AudioCompress/config.h \
+ src/AudioCompress/compress.h \
src/AudioCompress/compress.c \
src/MixRampInfo.hxx \
src/MusicBuffer.cxx src/MusicBuffer.hxx \
@@ -143,7 +137,7 @@ src_mpd_SOURCES = \
src/Permission.cxx src/Permission.hxx \
src/PlayerThread.cxx src/PlayerThread.hxx \
src/PlayerControl.cxx src/PlayerControl.hxx \
- src/Playlist.cxx \
+ src/Playlist.cxx src/Playlist.hxx \
src/PlaylistError.cxx src/PlaylistError.hxx \
src/PlaylistGlobal.cxx src/PlaylistGlobal.hxx \
src/PlaylistControl.cxx \
@@ -177,10 +171,11 @@ src_mpd_SOURCES = \
src/TagSave.cxx src/TagSave.hxx \
src/TagFile.cxx src/TagFile.hxx \
src/TagStream.cxx src/TagStream.hxx \
+ src/TimePrint.cxx src/TimePrint.hxx \
src/mixer/Volume.cxx src/mixer/Volume.hxx \
src/SongFilter.cxx src/SongFilter.hxx \
src/PlaylistFile.cxx src/PlaylistFile.hxx \
- src/Timer.cxx
+ src/Timer.cxx src/Timer.hxx
if ENABLE_DATABASE
src_mpd_SOURCES += \