aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-07-30 10:15:31 +0200
committerMax Kellermann <max@duempel.org>2014-07-30 10:15:37 +0200
commit88615fbff1ba25ac0c4ad21b7f321940652a389c (patch)
tree173356fb12eef7cfbb358fdb6b11f7a8bdf9cc98 /Makefile.am
parentd4f8f6717334f84f94d7544e8fcd77b7346e156b (diff)
downloadmpd-88615fbff1ba25ac0c4ad21b7f321940652a389c.tar.gz
mpd-88615fbff1ba25ac0c4ad21b7f321940652a389c.tar.xz
mpd-88615fbff1ba25ac0c4ad21b7f321940652a389c.zip
Makefile.am: move duplicate specification to APK_DEPS
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 345f82ebe..24ee74894 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -298,10 +298,14 @@ android/build/res/drawable/icon.png: mpd.svg
mkdir -p $(@D)
rsvg-convert --width=48 --height=48 $< -o $@
-android/build/bin/Main-debug.apk: android/build/build.xml android/build/res/drawable/icon.png android/build/libs/armeabi-v7a/libmpd.so
+APK_DEPS = android/build/res/drawable/icon.png \
+ android/build/libs/armeabi-v7a/libmpd.so \
+ android/build/build.xml
+
+android/build/bin/Main-debug.apk: $(APK_DEPS)
cd android/build && ant nodeps debug
-android/build/bin/Main-release-unsigned.apk: android/build/build.xml android/build/res/drawable/icon.png android/build/libs/armeabi-v7a/libmpd.so
+android/build/bin/Main-release-unsigned.apk: $(APK_DEPS)
cd android/build && ant nodeps release
android/build/bin/Main-release-unaligned.apk: android/build/bin/Main-release-unsigned.apk