aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-02-07 20:27:24 +0100
committerMax Kellermann <max@duempel.org>2014-02-07 20:27:24 +0100
commit8549ccfd8c24c5666435ac4dd00ba3c7d14e0351 (patch)
tree3b7820e956b3b494dff1a21be97baa311f1ff1cb /Makefile.am
parentffd16b55a69a01b906805752acc11e26491138bc (diff)
downloadmpd-8549ccfd8c24c5666435ac4dd00ba3c7d14e0351.tar.gz
mpd-8549ccfd8c24c5666435ac4dd00ba3c7d14e0351.tar.xz
mpd-8549ccfd8c24c5666435ac4dd00ba3c7d14e0351.zip
playlist/CloseSongEnumerator: new wrapper class
Simplifies a lot of code, because we don't need to return both the SongEnumerator and the InputStream.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 374c09f52..19e4b255d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1150,6 +1150,8 @@ endif
libplaylist_plugins_a_SOURCES = \
src/playlist/PlaylistPlugin.hxx \
src/playlist/SongEnumerator.hxx \
+ src/playlist/CloseSongEnumerator.cxx \
+ src/playlist/CloseSongEnumerator.hxx \
src/playlist/MemorySongEnumerator.cxx \
src/playlist/MemorySongEnumerator.hxx \
src/playlist/plugins/ExtM3uPlaylistPlugin.cxx \