aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2011-09-20 20:51:46 +0200
committerMax Kellermann <max@duempel.org>2011-09-20 21:15:05 +0200
commit7d9d459ac2c71e0b3598ed0f606cd2d550853838 (patch)
tree881821c611654010287da59eb27d50cac79a49f5 /Makefile.am
parent3ea1073809bf324e5b75fd33d61dcb0422463358 (diff)
downloadmpd-7d9d459ac2c71e0b3598ed0f606cd2d550853838.tar.gz
mpd-7d9d459ac2c71e0b3598ed0f606cd2d550853838.tar.xz
mpd-7d9d459ac2c71e0b3598ed0f606cd2d550853838.zip
resolver: add function resolve_host_port()
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9e7095159..900f0b421 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -903,6 +903,7 @@ TESTS = $(C_TESTS)
noinst_PROGRAMS = \
$(C_TESTS) \
test/read_conf \
+ test/run_resolver \
test/run_input \
test/dump_playlist \
test/run_decoder \
@@ -926,6 +927,11 @@ test_read_conf_LDADD = $(MPD_LIBS) \
test_read_conf_SOURCES = test/read_conf.c \
src/conf.c src/tokenizer.c src/utils.c src/string_util.c
+test_run_resolver_LDADD = $(MPD_LIBS) \
+ $(GLIB_LIBS)
+test_run_resolver_SOURCES = test/run_resolver.c \
+ src/resolver.c
+
test_run_input_CPPFLAGS = $(AM_CPPFLAGS) \
$(ARCHIVE_CFLAGS) \
$(INPUT_CFLAGS)