aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRobert Vollmert <rvollmert@gmx.net>2012-02-27 13:19:45 +0100
committerMax Kellermann <max@duempel.org>2012-03-01 20:11:09 +0100
commit7cef52478dc2d5c5b9d2a75e34e4e57ca5cdb122 (patch)
tree1aa8b8a61aba3963f8cf376f4ab9310b0f98d3f2 /Makefile.am
parente7ce362d22dd2292a357b167b74dccefc2b7612b (diff)
downloadmpd-7cef52478dc2d5c5b9d2a75e34e4e57ca5cdb122.tar.gz
mpd-7cef52478dc2d5c5b9d2a75e34e4e57ca5cdb122.tar.xz
mpd-7cef52478dc2d5c5b9d2a75e34e4e57ca5cdb122.zip
A soundcloud playlist plugin.
Requires YAJL to build, and this doesn't include the necessary automake changes. Can be built using ./configure CFLAGS="-I/usr/include/yajl" LIBS="-lyajl" --enable-soundcloud Add the following to your config: playlist_plugin { name "soundcloud" enabled "true" apikey "c4c979fd6f241b5b30431d722af212e8" } Then you can stream from soundcloud using calls like: mpc load soundcloud://track/<track-id> mpc load soundcloud://playlist/<playlist-id> mpc load soundcloud://url/http://soundcloud.com/some/track/or/playlist For the last case, you can leave off the http:// or http://soundcloud.com/ .
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 07782fdcb..ec78f6b96 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -902,6 +902,12 @@ if ENABLE_DESPOTIFY
libplaylist_plugins_a_SOURCES += src/playlist/despotify_playlist_plugin.c
endif
+if ENABLE_SOUNDCLOUD
+libplaylist_plugins_a_SOURCES += \
+ src/playlist/soundcloud_playlist_plugin.h \
+ src/playlist/soundcloud_playlist_plugin.c
+PLAYLIST_LIBS += -lyajl
+endif
#
# Filter plugins