aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-03-10 15:46:55 +0100
committerMax Kellermann <max@duempel.org>2009-03-10 15:46:55 +0100
commit79ef9166df2cf1c431e2bbbd4e19de3de7773324 (patch)
tree63ef1db845fcf34efd408c95568444d3ae7eda90 /Makefile.am
parent296c1bb3b696b0e57d2d70aedb85cdecd231a787 (diff)
downloadmpd-79ef9166df2cf1c431e2bbbd4e19de3de7773324.tar.gz
mpd-79ef9166df2cf1c431e2bbbd4e19de3de7773324.tar.xz
mpd-79ef9166df2cf1c431e2bbbd4e19de3de7773324.zip
test: added program "run_output"
The "run_output" program can be used to test an audio output plugin in an isolated environment.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b6d95030d..d406220eb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -531,6 +531,7 @@ noinst_PROGRAMS = \
test/run_decoder \
test/read_tags \
test/run_encoder \
+ test/run_output \
test/software_volume
test_run_decoder_CPPFLAGS = $(AM_CPPFLAGS) \
@@ -575,6 +576,21 @@ test_software_volume_SOURCES = test/software_volume.c \
src/audio_parser.c \
src/pcm_volume.c
+test_run_output_CPPFLAGS = $(AM_CPPFLAGS) \
+ $(ENCODER_CFLAGS) \
+ $(OUTPUT_CFLAGS)
+test_run_output_LDADD = $(MPD_LIBS) \
+ $(ENCODER_LIBS) \
+ $(OUTPUT_LIBS)
+test_run_output_SOURCES = test/run_output.c \
+ src/conf.c src/buffer2array.c src/utils.c src/log.c \
+ src/audio_parser.c \
+ src/timer.c \
+ src/output_init.c src/output_list.c \
+ $(ENCODER_SRC) \
+ $(MIXER_SRC) \
+ $(OUTPUT_SRC)
+
if HAVE_ID3TAG
test_run_decoder_SOURCES += src/tag_id3.c src/riff.c src/aiff.c
test_read_tags_SOURCES += src/tag_id3.c src/riff.c src/aiff.c