aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorFrançois Revol <revol@free.fr>2015-09-17 22:18:16 +0200
committerMax Kellermann <max@duempel.org>2015-09-17 22:46:46 +0200
commit7743647460575fd9ea4d5e29e5a23e3faf56c58c (patch)
tree345a617582882dbe72170e4f09248fcb0867b940 /Makefile.am
parent352ec364f02aaf40fee571a1f7258cb3be0c17f3 (diff)
downloadmpd-7743647460575fd9ea4d5e29e5a23e3faf56c58c.tar.gz
mpd-7743647460575fd9ea4d5e29e5a23e3faf56c58c.tar.xz
mpd-7743647460575fd9ea4d5e29e5a23e3faf56c58c.zip
output: add native Haiku audio output and mixer support
Also uses the notification system to display tags.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e4dc88a7d..155a6a743 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1355,6 +1355,14 @@ liboutput_plugins_a_SOURCES += \
src/output/plugins/FifoOutputPlugin.hxx
endif
+if HAVE_HAIKU
+liboutput_plugins_a_SOURCES += \
+ src/output/plugins/HaikuOutputPlugin.cxx \
+ src/output/plugins/HaikuOutputPlugin.hxx
+libmixer_plugins_a_SOURCES += \
+ src/mixer/plugins/HaikuMixerPlugin.cxx src/mixer/plugins/HaikuMixerPlugin.hxx
+endif
+
if ENABLE_PIPE_OUTPUT
liboutput_plugins_a_SOURCES += \
src/output/plugins/PipeOutputPlugin.cxx \