aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2012-04-23 22:30:06 +0200
committerMax Kellermann <max@duempel.org>2012-04-23 23:00:41 +0200
commit6b52d040b1b0c6a1697d54274d56e61a4e383dca (patch)
tree433985dc9eaaf73d6e6acc8b1f7e445818999248 /Makefile.am
parent404fa8993714f59f8708a3ce937248bab9bdc3f2 (diff)
downloadmpd-6b52d040b1b0c6a1697d54274d56e61a4e383dca.tar.gz
mpd-6b52d040b1b0c6a1697d54274d56e61a4e383dca.tar.xz
mpd-6b52d040b1b0c6a1697d54274d56e61a4e383dca.zip
test/read_rva2: new debug program for the RVA2 library
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 38d08f098..c0cbbd99b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -999,6 +999,10 @@ noinst_PROGRAMS = \
test/run_normalize \
test/software_volume
+if HAVE_ID3TAG
+noinst_PROGRAMS += test/dump_rva2
+endif
+
if HAVE_ALSA
# this debug program is still ALSA specific
noinst_PROGRAMS += test/read_mixer
@@ -1116,6 +1120,17 @@ test_read_tags_SOURCES = test/read_tags.c \
src/timer.c \
$(DECODER_SRC)
+if HAVE_ID3TAG
+test_dump_rva2_LDADD = \
+ $(ID3TAG_LIBS) \
+ $(GLIB_LIBS)
+test_dump_rva2_SOURCES = test/dump_rva2.c \
+ src/riff.c src/aiff.c \
+ src/tag_handler.c \
+ src/tag_id3.c \
+ src/tag_rva2.c
+endif
+
test_run_ntp_server_LDADD = \
$(GLIB_LIBS)
test_run_ntp_server_SOURCES = test/run_ntp_server.c \