aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2011-09-05 22:53:46 +0200
committerMax Kellermann <max@duempel.org>2012-08-08 01:20:45 +0200
commit63a2ac21e1d8190448057fbf24d5ab948d3daff8 (patch)
treed7e8620ebdb73a10228dd4ae1091821c77c02a2c /Makefile.am
parentc42b20629265a953ecced484a29d7208bcff367b (diff)
downloadmpd-63a2ac21e1d8190448057fbf24d5ab948d3daff8.tar.gz
mpd-63a2ac21e1d8190448057fbf24d5ab948d3daff8.tar.xz
mpd-63a2ac21e1d8190448057fbf24d5ab948d3daff8.zip
ProxyDatabasePlugin: new database plugin using libmpdclient
Implementation incomplete, but sort-of-works. DumpDatabase works, but MPD is still hard-coded on the "simple" plugin.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ec55c1bb6..4e84dc30e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,6 +20,7 @@ noinst_LIBRARIES = \
liboutput_plugins.a
src_mpd_CPPFLAGS = $(AM_CPPFLAGS) \
+ $(LIBMPDCLIENT_CFLAGS) \
$(AVAHI_CFLAGS) \
$(LIBWRAP_CFLAGS) \
$(SQLITE_CFLAGS)
@@ -437,7 +438,13 @@ libdb_plugins_a_SOURCES = \
src/DatabaseRegistry.cxx src/DatabaseRegistry.hxx \
src/db/SimpleDatabasePlugin.cxx src/db/SimpleDatabasePlugin.hxx
+if HAVE_LIBMPDCLIENT
+libdb_plugins_a_SOURCES += \
+ src/db/ProxyDatabasePlugin.cxx src/db/ProxyDatabasePlugin.hxx
+endif
+
DB_LIBS = \
+ $(LIBMPDCLIENT_LIBS) \
libdb_plugins.a
# archive plugins
@@ -1043,7 +1050,7 @@ test_run_resolver_SOURCES = test/run_resolver.c \
src/resolver.c
test_DumpDatabase_LDADD = \
- libdb_plugins.a \
+ $(DB_LIBS) \
libutil.a \
$(GLIB_LIBS)
test_DumpDatabase_SOURCES = test/DumpDatabase.cxx \