aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-04-21 22:46:41 +0200
committerMax Kellermann <max@duempel.org>2009-04-21 22:46:41 +0200
commit63710ff5a6fb51715aac83ca9374ef47f97d6120 (patch)
tree8daeb6caea4b18cdd247af97005497e4add2552f /Makefile.am
parentc7c809ecba1ce0dd005c9235f189021558f4b984 (diff)
downloadmpd-63710ff5a6fb51715aac83ca9374ef47f97d6120.tar.gz
mpd-63710ff5a6fb51715aac83ca9374ef47f97d6120.tar.xz
mpd-63710ff5a6fb51715aac83ca9374ef47f97d6120.zip
test: added program "read_mixer"
This little program is used to test mixer plugins in an isolated environment. This is ALSA-only currently, because we don't have a real "plugin list" yet, and I'm too lazy to implement a switch.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 2b77a3ba2..247bc3270 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -594,6 +594,7 @@ noinst_PROGRAMS = \
test/read_tags \
test/run_encoder \
test/run_output \
+ test/read_mixer \
test/software_volume
test_read_conf_CPPFLAGS = $(AM_CPPFLAGS) \
@@ -690,10 +691,15 @@ test_run_output_SOURCES = test/run_output.c \
$(MIXER_SRC) \
$(OUTPUT_SRC)
-if HAVE_ID3TAG
-test_run_decoder_SOURCES += src/tag_id3.c src/riff.c src/aiff.c
-test_read_tags_SOURCES += src/tag_id3.c src/riff.c src/aiff.c
-endif
+test_read_mixer_CPPFLAGS = $(AM_CPPFLAGS) \
+ $(OUTPUT_CFLAGS)
+test_read_mixer_LDADD = $(MPD_LIBS) \
+ $(OUTPUT_LIBS) \
+ $(GLIB_LIBS)
+test_read_mixer_SOURCES = test/read_mixer.c \
+ src/conf.c src/buffer2array.c src/utils.c src/log.c \
+ src/mixer_control.c src/mixer_api.c \
+ $(MIXER_SRC)
endif