aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-08-18 10:12:37 +0200
committerMax Kellermann <max@duempel.org>2014-08-18 10:12:37 +0200
commit636f5d4a1d983cdbb43b23da0da9c5db4a91f71f (patch)
treeaf88f1829d5d3f4883545b2af3db87682c9d5a40 /Makefile.am
parent41a4b280eea21dd584225bb394a0522ddf504964 (diff)
downloadmpd-636f5d4a1d983cdbb43b23da0da9c5db4a91f71f.tar.gz
mpd-636f5d4a1d983cdbb43b23da0da9c5db4a91f71f.tar.xz
mpd-636f5d4a1d983cdbb43b23da0da9c5db4a91f71f.zip
{input,decoder}/ffmpeg: move ffmpeg_domain to lib/ffmpeg/Domain.cxx
Eliminate duplicate definition (in input plugin and decoder plugin).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 44ce20fff..dbf8fb738 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -776,6 +776,15 @@ libtag_a_SOURCES += \
src/tag/Aiff.cxx src/tag/Aiff.hxx
endif
+# ffmpeg
+
+if HAVE_FFMPEG
+noinst_LIBRARIES += libffmpeg.a
+libffmpeg_a_SOURCES = \
+ src/lib/ffmpeg/Domain.cxx src/lib/ffmpeg/Domain.hxx
+FFMPEG_LIBS2 = libffmpeg.a $(FFMPEG_LIBS)
+endif
+
# decoder plugins
libdecoder_a_SOURCES = \
@@ -825,7 +834,7 @@ DECODER_LIBS = \
$(MPG123_LIBS) \
$(MP4V2_LIBS) \
$(OPUS_LIBS) \
- $(FFMPEG_LIBS) \
+ $(FFMPEG_LIBS2) \
$(MPCDEC_LIBS) \
$(ADPLUG_LIBS) \
$(FAAD_LIBS)
@@ -1104,7 +1113,7 @@ INPUT_LIBS = \
$(SMBCLIENT_LIBS) \
$(NFS_LIBS) \
$(CDIO_PARANOIA_LIBS) \
- $(FFMPEG_LIBS) \
+ $(FFMPEG_LIBS2) \
$(DESPOTIFY_LIBS) \
$(MMS_LIBS)