aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-07-14 23:07:41 +0200
committerMax Kellermann <max@duempel.org>2009-07-14 23:07:41 +0200
commit6233de05464c11b714cbfcb2692ff22691b1475a (patch)
tree074d6e00f9b85e0c7d840044ea8198b0aead2666 /Makefile.am
parentb1afa40fc12088818a01c810d8cf6617a3afe627 (diff)
downloadmpd-6233de05464c11b714cbfcb2692ff22691b1475a.tar.gz
mpd-6233de05464c11b714cbfcb2692ff22691b1475a.tar.xz
mpd-6233de05464c11b714cbfcb2692ff22691b1475a.zip
encoder/twolame: new encoder plugin based on libtwolame
This encoder plugin is a replacement for the LAME encoder plugin for those who prefer a "free" (non-patent encumbered) encoder library. Most of the plugin source code is copied from the LAME encoder plugin, since the LAME and TwoLAME APIs are nearly the same.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7b16b1116..5c53ca5c1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -432,10 +432,12 @@ endif
ENCODER_CFLAGS = \
$(LAME_CFLAGS) \
+ $(TWOLAME_CFLAGS) \
$(VORBISENC_CFLAGS)
ENCODER_LIBS = \
$(LAME_LIBS) \
+ $(TWOLAME_LIBS) \
$(VORBISENC_LIBS)
ENCODER_SRC =
@@ -450,6 +452,10 @@ endif
if ENABLE_LAME_ENCODER
ENCODER_SRC += src/encoder/lame_encoder.c
endif
+
+if ENABLE_TWOLAME_ENCODER
+ENCODER_SRC += src/encoder/twolame_encoder.c
+endif
endif