aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSerge Ziryukin <ftrvxmtrx@gmail.com>2010-07-25 14:04:24 +0200
committerMax Kellermann <max@duempel.org>2010-07-25 14:04:24 +0200
commit5cb061ebdf8cbc165747c60efcd763644d0c767e (patch)
treeb38c05fa56437c27eacb6b1e6fea58bafe9f0852 /Makefile.am
parent12f4225d6ba6ecf2b989719a287f8ed1f7fb6bf5 (diff)
downloadmpd-5cb061ebdf8cbc165747c60efcd763644d0c767e.tar.gz
mpd-5cb061ebdf8cbc165747c60efcd763644d0c767e.tar.xz
mpd-5cb061ebdf8cbc165747c60efcd763644d0c767e.zip
Makefile.am: simplify (de)installation of doxygen-generated documentation
This also fixes installation when no *.gif files found in 'doc/api/html' folder.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index ec38cf4ea..01abe578f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1113,10 +1113,12 @@ clean-local:
install-data-local: doc/api/html/index.html
$(mkinstalldirs) $(DESTDIR)$(docdir)/api/html
- $(INSTALL_DATA) -c -m 644 doc/api/html/*.html doc/api/html/*.css \
- doc/api/html/*.png doc/api/html/*.gif \
+ $(INSTALL_DATA) -c -m 644 doc/api/html/*.* \
$(DESTDIR)$(docdir)/api/html
+uninstall-local:
+ rm -f $(DESTDIR)$(docdir)/api/html/*.*
+
upload: $(DOCBOOK_HTML) doc/api/html/index.html
rsync -vpruz --delete doc/ cirrus@www.musicpd.org:/var/www/musicpd.org/www/doc/ \
--chmod=Dug+rwx,Do+rx,Fug+rw,Fo+r \