aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-11-19 21:00:46 +0100
committerMax Kellermann <max@duempel.org>2009-11-19 21:00:46 +0100
commit5a480137d2c724c8a3359c66a9120e310ea19cd1 (patch)
tree89cf499b6c302fc424946f922743bfeef12573ef /Makefile.am
parent943bafbbc896a85c247ec4ff23d2bd4cce348399 (diff)
downloadmpd-5a480137d2c724c8a3359c66a9120e310ea19cd1.tar.gz
mpd-5a480137d2c724c8a3359c66a9120e310ea19cd1.tar.xz
mpd-5a480137d2c724c8a3359c66a9120e310ea19cd1.zip
test: added program to test pcm_convert.c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 250360e01..58d1964e4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -741,6 +741,7 @@ noinst_PROGRAMS = \
test/run_filter \
test/run_output \
test/read_mixer \
+ test/run_convert \
test/software_volume
test_read_conf_CPPFLAGS = $(AM_CPPFLAGS) \
@@ -866,6 +867,25 @@ test_software_volume_SOURCES = test/software_volume.c \
test_software_volume_LDADD = \
$(GLIB_LIBS)
+test_run_convert_SOURCES = test/run_convert.c \
+ src/audio_check.c \
+ src/audio_parser.c \
+ src/pcm_channels.c \
+ src/pcm_format.c \
+ src/pcm_dither.c \
+ src/pcm_byteswap.c \
+ src/pcm_resample.c \
+ src/pcm_resample_fallback.c \
+ src/pcm_convert.c
+test_run_convert_CPPFLAGS = $(AM_CPPFLAGS) $(SAMPLERATE_CFLAGS)
+test_run_convert_LDADD = \
+ $(SAMPLERATE_LIBS) \
+ $(GLIB_LIBS)
+
+if HAVE_LIBSAMPLERATE
+test_run_convert_SOURCES += src/pcm_resample_libsamplerate.c
+endif
+
test_run_output_CPPFLAGS = $(AM_CPPFLAGS) \
$(ENCODER_CFLAGS) \
$(OUTPUT_CFLAGS)