aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-03-14 23:45:27 +0100
committerMax Kellermann <max@duempel.org>2014-03-15 11:41:01 +0100
commit5696f91a1e5e0cd1022c60737465c29b429ea599 (patch)
tree3b81b96802113065c28faf97af12503260c29551 /Makefile.am
parent3932e62fc7d8bc05e4f77c1b3cd69fd314cee3d1 (diff)
downloadmpd-5696f91a1e5e0cd1022c60737465c29b429ea599.tar.gz
mpd-5696f91a1e5e0cd1022c60737465c29b429ea599.tar.xz
mpd-5696f91a1e5e0cd1022c60737465c29b429ea599.zip
pcm/PcmFormat: ARM NEON optimizations for float->s16
This is nearly 4 times faster than the "portable" algorithm.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e1a5415d8..700511338 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -452,6 +452,7 @@ libpcm_a_SOURCES = \
src/pcm/PcmFormat.cxx src/pcm/PcmFormat.hxx \
src/pcm/FloatConvert.hxx \
src/pcm/ShiftConvert.hxx \
+ src/pcm/Neon.hxx \
src/pcm/FormatConverter.cxx src/pcm/FormatConverter.hxx \
src/pcm/ChannelsConverter.cxx src/pcm/ChannelsConverter.hxx \
src/pcm/Resampler.hxx \