aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-01-23 21:21:27 +0100
committerMax Kellermann <max@duempel.org>2014-01-23 21:22:52 +0100
commit53a13e8bc6da1f7a795a8d585974d917ffcb600c (patch)
treea4be817f8fc62d5fc75bf9d6b07b69bf53190269 /Makefile.am
parentf3f5e2e16231f8b7bef055ca1269611bcbbfcc8b (diff)
downloadmpd-53a13e8bc6da1f7a795a8d585974d917ffcb600c.tar.gz
mpd-53a13e8bc6da1f7a795a8d585974d917ffcb600c.tar.xz
mpd-53a13e8bc6da1f7a795a8d585974d917ffcb600c.zip
DetachedSong: un-inline the destructor
Reduce bloat.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index eaed7cb0a..cc44fc505 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1235,6 +1235,7 @@ test_DumpDatabase_SOURCES = test/DumpDatabase.cxx \
src/PlaylistVector.cxx src/PlaylistDatabase.cxx \
src/DatabaseLock.cxx src/DatabaseSave.cxx \
src/Song.cxx src/SongSave.cxx src/SongSort.cxx \
+ src/DetachedSong.cxx \
src/TagSave.cxx \
src/SongFilter.cxx
@@ -1329,6 +1330,7 @@ test_dump_playlist_SOURCES = test/dump_playlist.cxx \
if HAVE_FLAC
test_dump_playlist_SOURCES += \
src/ReplayGainInfo.cxx \
+ src/DetachedSong.cxx \
src/decoder/FlacMetadata.cxx
endif
@@ -1645,6 +1647,7 @@ test_test_translate_song_LDADD = \
test_test_queue_priority_SOURCES = \
src/Queue.cxx \
+ src/DetachedSong.cxx \
test/test_queue_priority.cxx
test_test_queue_priority_CPPFLAGS = $(AM_CPPFLAGS) $(CPPUNIT_CFLAGS) -DCPPUNIT_HAVE_RTTI=0
test_test_queue_priority_CXXFLAGS = $(AM_CXXFLAGS) -Wno-error=deprecated-declarations