aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-09-04 23:46:20 +0200
committerMax Kellermann <max@duempel.org>2013-09-04 23:46:20 +0200
commit5101ef4b028c8f661801f78ba0fe73fab0e80f7f (patch)
tree5a5b83c5132724ff1793900162eab3b5f648c218 /Makefile.am
parentee9e238179677ad0168ead6edfe17f798dbf47dc (diff)
downloadmpd-5101ef4b028c8f661801f78ba0fe73fab0e80f7f.tar.gz
mpd-5101ef4b028c8f661801f78ba0fe73fab0e80f7f.tar.xz
mpd-5101ef4b028c8f661801f78ba0fe73fab0e80f7f.zip
Tag*: move libtag.a sources to src/tag/
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 9 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index 2ad19c3c8..cfdc42c6c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -63,8 +63,6 @@ mpd_headers = \
src/open.h \
src/Playlist.hxx \
src/poison.h \
- src/riff.h \
- src/aiff.h \
src/replay_gain_config.h \
src/replay_gain_info.h \
src/TimePrint.cxx src/TimePrint.hxx \
@@ -432,15 +430,16 @@ TAG_LIBS = \
$(ID3TAG_LIBS)
libtag_a_SOURCES =\
- src/ApeLoader.cxx src/ApeLoader.hxx \
- src/ApeReplayGain.cxx src/ApeReplayGain.hxx \
- src/ApeTag.cxx src/ApeTag.hxx
+ src/tag/ApeLoader.cxx src/tag/ApeLoader.hxx \
+ src/tag/ApeReplayGain.cxx src/tag/ApeReplayGain.hxx \
+ src/tag/ApeTag.cxx src/tag/ApeTag.hxx
if HAVE_ID3TAG
libtag_a_SOURCES += \
- src/TagId3.cxx src/TagId3.hxx \
- src/TagRva2.cxx src/TagRva2.hxx \
- src/riff.c src/aiff.c
+ src/tag/TagId3.cxx src/tag/TagId3.hxx \
+ src/tag/TagRva2.cxx src/tag/TagRva2.hxx \
+ src/tag/riff.c src/tag/riff.h \
+ src/tag/aiff.c src/tag/aiff.h
endif
# decoder plugins
@@ -1218,14 +1217,11 @@ test_read_tags_SOURCES = test/read_tags.cxx \
if HAVE_ID3TAG
test_dump_rva2_LDADD = \
- $(ID3TAG_LIBS) \
+ $(TAG_LIBS) \
libutil.a \
$(GLIB_LIBS)
test_dump_rva2_SOURCES = test/dump_rva2.cxx \
- src/riff.c src/aiff.c \
- src/TagHandler.cxx \
- src/TagId3.cxx \
- src/TagRva2.cxx
+ src/TagHandler.cxx
endif
test_run_filter_LDADD = \