aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-03-28 21:38:44 +0100
committerMax Kellermann <max@duempel.org>2009-03-28 21:38:44 +0100
commit50c53e4b24085174fbe8267d4da2b51711543374 (patch)
treeb8a9e3b8eeedaa8d2e19e3ecaa11a4d797c54ee2 /Makefile.am
parentde7c16d1be09f6771a4b95b14ff1201b9f4ef931 (diff)
downloadmpd-50c53e4b24085174fbe8267d4da2b51711543374.tar.gz
mpd-50c53e4b24085174fbe8267d4da2b51711543374.tar.xz
mpd-50c53e4b24085174fbe8267d4da2b51711543374.zip
Makefile.am: use SAMPLERATE_CFLAGS and SAMPLERATE_LIBS
Don't add those to MPD_CFLAGS and MPD_LIBS.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index dfbaf37c1..249383150 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,6 +12,7 @@ src_mpd_CPPFLAGS = $(AM_CPPFLAGS) \
$(INPUT_CFLAGS) \
$(DECODER_CFLAGS) \
$(ENCODER_CFLAGS) \
+ $(FILTER_CFLAGS) \
$(OUTPUT_CFLAGS)
src_mpd_LDADD = $(MPD_LIBS) \
$(SQLITE_LIBS) \
@@ -20,6 +21,7 @@ src_mpd_LDADD = $(MPD_LIBS) \
$(DECODER_LIBS) \
$(ENCODER_LIBS) \
$(OUTPUT_LIBS) \
+ $(FILTER_LIBS) \
$(GLIB_LIBS)
mpd_headers = \
@@ -243,6 +245,11 @@ if ENABLE_SQLITE
src_mpd_SOURCES += src/sticker.c src/song_sticker.c
endif
+FILTER_CFLAGS = \
+ $(SAMPLERATE_CFLAGS)
+FILTER_LIBS = \
+ $(SAMPLERATE_LIBS)
+
if HAVE_LIBSAMPLERATE
src_mpd_SOURCES += src/pcm_resample_libsamplerate.c
endif