aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-08-24 18:57:06 +0200
committerMax Kellermann <max@duempel.org>2009-08-24 18:57:06 +0200
commit4a0d4a02a64774c61840496c8141b89ed31d1d94 (patch)
treeaeb8928d8d7653f4b0e81a53d71ff4d8edb0d6ca /Makefile.am
parent4231ec51c319ee43e06e9ab291696d8f1a546564 (diff)
downloadmpd-4a0d4a02a64774c61840496c8141b89ed31d1d94.tar.gz
mpd-4a0d4a02a64774c61840496c8141b89ed31d1d94.tar.xz
mpd-4a0d4a02a64774c61840496c8141b89ed31d1d94.zip
output/recorder: new output plugin for recording radio streams
The recorder plugin writes audio played by MPD to a file. This may be useful for recording radio streams. This implementation is incomplete, because support for tags is missing, and MPD should be able to record each track to a different file.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c3d8b4a18..8e1341f0f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -597,6 +597,10 @@ if HAVE_SHOUT
OUTPUT_SRC += src/output/shout_plugin.c
endif
+if ENABLE_RECORDER_OUTPUT
+OUTPUT_SRC += src/output/recorder_output_plugin.c
+endif
+
if ENABLE_HTTPD_OUTPUT
OUTPUT_SRC += \
src/icy_server.c \