aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-09-04 15:15:58 +0200
committerMax Kellermann <max@duempel.org>2014-09-04 17:10:30 +0200
commit4907f610d6116949111fb6ff81c1489ec68b9d43 (patch)
tree330a1a6fa0ccf0f0440b489db88caea90ff39734 /Makefile.am
parentf9d1bbbffb7bc068aa00d4040d8beefc1a66bad8 (diff)
downloadmpd-4907f610d6116949111fb6ff81c1489ec68b9d43.tar.gz
mpd-4907f610d6116949111fb6ff81c1489ec68b9d43.tar.xz
mpd-4907f610d6116949111fb6ff81c1489ec68b9d43.zip
test/test_protocol: unit test for protocol/ArgParser.cxx
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6a5e9fb27..147a15bf8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1064,6 +1064,7 @@ C_TESTS = \
test/test_mixramp \
test/test_icy_parser \
test/test_pcm \
+ test/test_protocol \
test/test_queue_priority
if ENABLE_ARCHIVE
@@ -1538,6 +1539,16 @@ test_test_archive_LDADD = \
$(GLIB_LIBS) \
$(CPPUNIT_LIBS)
+test_test_protocol_SOURCES = \
+ src/protocol/ArgParser.cxx \
+ test/test_protocol.cxx
+test_test_protocol_CPPFLAGS = $(AM_CPPFLAGS) $(CPPUNIT_CFLAGS) -DCPPUNIT_HAVE_RTTI=0
+test_test_protocol_CXXFLAGS = $(AM_CXXFLAGS) -Wno-error=deprecated-declarations
+test_test_protocol_LDADD = \
+ libsystem.a \
+ libutil.a \
+ $(CPPUNIT_LIBS)
+
test_test_queue_priority_SOURCES = \
src/Queue.cxx \
test/test_queue_priority.cxx