aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-12-01 20:55:05 +0100
committerMax Kellermann <max@duempel.org>2014-12-01 20:55:05 +0100
commit4658bd8208613bad3c987ee5083e1b6c5481f037 (patch)
tree938d280afab3daa90f287d3beff38b053b5289cd /Makefile.am
parent6eb1caa417187d0321b64fc17386d0cad3078614 (diff)
downloadmpd-4658bd8208613bad3c987ee5083e1b6c5481f037.tar.gz
mpd-4658bd8208613bad3c987ee5083e1b6c5481f037.tar.xz
mpd-4658bd8208613bad3c987ee5083e1b6c5481f037.zip
test/TestIcu: new unit test for lib/icu/*
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 16cd80b9a..f126efeee 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -465,6 +465,7 @@ libicu_a_CPPFLAGS = $(AM_CPPFLAGS) \
$(ICU_CFLAGS)
ICU_LDADD = libicu.a $(ICU_LIBS)
+ICU_LDADD += $(GLIB_LIBS)
# PCM library
@@ -1484,7 +1485,8 @@ C_TESTS = \
test/test_mixramp \
test/test_pcm \
test/test_protocol \
- test/test_queue_priority
+ test/test_queue_priority \
+ test/TestIcu
if ENABLE_CURL
C_TESTS += test/test_icy_parser
@@ -2121,6 +2123,15 @@ test_test_queue_priority_LDADD = \
libutil.a \
$(CPPUNIT_LIBS)
+test_TestIcu_SOURCES = \
+ test/TestIcu.cxx
+test_TestIcu_CPPFLAGS = $(AM_CPPFLAGS) $(CPPUNIT_CFLAGS) -DCPPUNIT_HAVE_RTTI=0
+test_TestIcu_CXXFLAGS = $(AM_CXXFLAGS) -Wno-error=deprecated-declarations
+test_TestIcu_LDADD = \
+ $(ICU_LDADD) \
+ libutil.a \
+ $(CPPUNIT_LIBS)
+
if ENABLE_DSD
noinst_PROGRAMS += src/pcm/dsd2pcm/dsd2pcm