aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2011-08-29 09:21:00 +0200
committerMax Kellermann <max@duempel.org>2011-08-29 09:39:03 +0200
commit453368078be8e79955a66ea9ca63efd6c3095850 (patch)
tree9d5cb916a3078600af64024371a09ec206487802 /Makefile.am
parent6e3b643bdf5f96c63c65dd83cfe6e19161fa0724 (diff)
downloadmpd-453368078be8e79955a66ea9ca63efd6c3095850.tar.gz
mpd-453368078be8e79955a66ea9ca63efd6c3095850.tar.xz
mpd-453368078be8e79955a66ea9ca63efd6c3095850.zip
configure.ac: add OpenSSL check for RAOP output plugin
Auto-enable the plugin when OpenSSL was found.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 161d6a92b..7047eb10e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -689,6 +689,7 @@ OUTPUT_CFLAGS = \
$(FFADO_CFLAGS) \
$(JACK_CFLAGS) \
$(OPENAL_CFLAGS) \
+ $(OPENSSL_CFLAGS) \
$(PULSE_CFLAGS) \
$(SHOUT_CFLAGS)
@@ -777,6 +778,7 @@ OUTPUT_SRC += \
src/ntp_server.c src/ntp_server.h \
src/output/raop_output_plugin.c
MIXER_SRC += src/mixer/raop_mixer_plugin.c
+OUTPUT_LIBS += $(OPENSSL_LIBS)
endif
if HAVE_PULSE