aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-03-02 23:11:31 +0100
committerMax Kellermann <max@duempel.org>2009-03-02 23:11:31 +0100
commit4220e6b0adccf2f09a82fb85768b7aecc5744b6c (patch)
tree55509fd1eb5dcbad42a7f0c3af7a19107a2e9647 /Makefile.am
parent9cd5b0af74b61967164598382e5ef66774e766a8 (diff)
downloadmpd-4220e6b0adccf2f09a82fb85768b7aecc5744b6c.tar.gz
mpd-4220e6b0adccf2f09a82fb85768b7aecc5744b6c.tar.xz
mpd-4220e6b0adccf2f09a82fb85768b7aecc5744b6c.zip
input_lastfm: new input plugin for last.fm radio
The lastfm input plugin enables MPD to play lastfm:// URLs. This plugin is not complete yet: it plays only the first song in the last.fm playlist, and the playlist parser isn't even implemented properly.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c0941967a..da0b87103 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -71,6 +71,7 @@ mpd_headers = \
src/input_stream.h \
src/input/file_input_plugin.h \
src/input/curl_input_plugin.h \
+ src/input/lastfm_input_plugin.h \
src/input/mms_input_plugin.h \
src/icy_metadata.h \
src/client.h \
@@ -414,6 +415,10 @@ if HAVE_CURL
INPUT_SRC += src/input/curl_input_plugin.c src/icy_metadata.c
endif
+if ENABLE_LASTFM
+INPUT_SRC += src/input/lastfm_input_plugin.c
+endif
+
if ENABLE_MMS
INPUT_SRC += src/input/mms_input_plugin.c
endif